通达信软件    金融实验室    Level2产品    港股产品     美股产品     帮助中心     通达信PC产品2群 通达信PC产品2群 通达信移动产品群 通达信移动产品提升群

通达信用户反馈区软件纵横公式天堂 → 通达信客服公式汇总贴


  共有134494人关注过本帖树形打印

主题:通达信客服公式汇总贴

美女呀,离线,留言给我吧!
晨云飞燕
  31楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/27 17:29:00

 

涨跌停系列

1.N天内经常涨停:

参数设置:

N1:1,250,100;

N21,250,8

{涨停}

ZTTJ:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));

COUNT(ZTTJ,N1)>=N2;

{跌停}

DTTJ:=(CLOSE<=DTPRICE(REF(CLOSE,1),0.1));
COUNT(DTTJ,N 1)>=N2;

2.N天内出现涨停:

参数设置:

N11,100,20

{涨停}

EZT:=(HIGH>=ZTPRICE(REF(CLOSE,1),0.1)); { 出现过涨停 }

EZTO:EXIST(EZT,N1); { N1天内存在过涨停 };

{跌停}

EDT:=(LOW<=DTPRICE(REF(CLOSE,1),0.1)); { 出现过涨停 }
EDTO:EXIST(EDT,N1); { N
1天内存在过涨停 };

3.N天内出现以涨停收盘:

参数设置:

N11,100,10

{涨停}

ZT:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1)); { 以涨停收盘 }

ZTO:EXIST(ZT,N1); { N1天存在以涨停收盘 };

{跌停}

DT:=(CLOSE<=DTPRICE(REF(CLOSE,1),0.1)); { 以涨停收盘 }
DTO:EXIST(DT,N1); { N1
天存在以涨停收盘 };


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  32楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/28 17:06:00

 

画线

1.折线:

分析图有两条均线m1m2m1m2上叉的焦点为A,然后,m1m2下叉的交点为B,再后是m1m2上叉焦点为C,将AB连接并延长,BC连接并延长

A1:MA(C,5);

A2:MA(C,10);

AA:=CROSS(A1,A2);

BB:=CROSS(A2,A1);

PLOYLINE(AA OR BB,A1);

2.波峰波谷相连

N:=20;

A1:=HHV(H,3)=ZIG(H,N);

A2:=LLV(L,3)=ZIG(L,N);

DRAWLINE(A1,H,A2,L,0),COLORYELLOW;

DRAWLINE(A2,L,A1,H,0),COLORYELLOW;

3. 每月高点向右划线的公式,要求以每月高点为划线的起点,划到下月高点处

A4:REF(H,BARSLAST(H=H#MONTH));


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  33楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/5/3 17:47:00

 引用外部数据

1.功能>公式系统>自定义数据管理器>新建,命名,属性选择序列数据(有日期),修改数据,导入你的文件。

2.建一个公式:

{SIGNALS_USER(1,1);}

DRAWNUMBER(C>0,H,SIGNALS_USER(1,1));

3.有的数据输出需要CON2STRVAR2STR或者STR2CON进行转换,再用DRAWTEXTDRAWNUMBER_FIX函数输出

CON2STRVAR2STR函数的应用

旋转转换成字符串,再用DRAWTEXTDRAWNUMBER_FIX函数输出:

A1:DRAWTEXT(CLOSE>OPEN AND CURRBARSCOUNT=20,LOW,CON2STR(C,3));

A2:DRAWTEXT(CLOSE>OPEN AND CURRBARSCOUNT=20,LOW,VAR2STR(C,3));


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  34楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/5/23 17:12:00

关于日线反周值:

问:DRAWICON(C>REF(H#WEEK,1),L,5) 今天的收盘价大于上一周的最高价,C>REF(H#WEEK,1)符合条件的为何只提示星期一的,后面的没有提示?

答:REF(H#WEEK,N)返回的是上N个交易日为参考日计算的H#WEEK,简单的说就是若当前是星期三,在日线,需要用REF(H#WEEK,3)返回3天前状态下的那一周最高价。

ZO:=OPEN#WEEK;ZC:=CLOSE#WEEK;ZH:=HIGH#WEEK;ZL:=LOW#WEEK;

STICKLINE(ZC>ZO,ZC,ZO,5,0),COLORLIGRAY;

STICKLINE(ZC<ZO,ZC,ZO,5,0),COLORLICYAN;

STICKLINE(WEEKDAY==3 AND ZC>ZO,ZH,ZL,2,0),COLORLIGRAY;

STICKLINE(WEEKDAY==3 AND ZC<ZO,ZH,ZL,2,0),COLORLICYAN;

DRAWKLINE(H,O,L,C);

ZQ:=IF(WEEKDAY=1,1,IF(WEEKDAY=2,2,IF(WEEKDAY=3,3,IF(WEEKDAY=4,4,5))));

DRAWICON(C>REF(ZH,ZQ),L,5);


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  35楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/6/29 11:07:00

 大参数计算数值的指标应用说明

例如用到TOTALBARSCOUNT、COUNT、SUM等函数,或是MA(C,N),N>700+的指标。

1.若指标必须放在副图中并且有实时性要求:

参数范围在420~700内的,可以在系统设置>设置2中将初始分析数据个数设置为700(快速网络支持的情况下);

     


图片点击可在新窗口打开查看此主题相关图片如下1.png:
图片点击可在新窗口打开查看
 

2.若指标必须放在副图中但是没有实时性要求:

在系统设置>设置1中勾选分析图使用下载的沪深日线数据;

 


图片点击可在新窗口打开查看此主题相关图片如下2.png:
图片点击可在新窗口打开查看


 

3.若指标可以不放在副图但是要求实时性:

把指标放在.401历史行情.指标排序中,右键附加排序指标,还可进行排序;

 


图片点击可在新窗口打开查看此主题相关图片如下3.png:
图片点击可在新窗口打开查看

支持(0中立(0反对(0回到顶部
总数 35 上一页 1 2 3 4