通达信软件    金融实验室    Level2产品    港股产品     美股产品     帮助中心     通达信PC产品3群 通达信PC讨论3群 通达信移动产品群 通达信移动产品提升群

通达信用户反馈区软件纵横公式天堂 → 通达信公式片段


  共有26876人关注过本帖树形打印

主题:通达信公式片段

帅哥哟,离线,有人找我吗?
tdxistdx
  1楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:管理员 帖子:1959 积分:10236 威望:0 精华:0 注册:2012/5/12 12:58:00
通达信公式片段  发帖心情 Post By:2013/5/18 12:34:00

贴子已被锁定


1.得到日内交易模型的开盘,最高价,结算价

最高价:HHV(H,BARSLAST(DATE!=REF(DATE,1))+1);
开盘价:VALUEWHEN(DATE!=REF(DATE,1),O);

2.在一分钟周期取前一天最高价、最低价怎么取?
N:=barslast(date!=ref(date,1))+1;
preDayHigh:ref(hhv(h,N),N);
preDayLOW:ref(LLv(L,N),N);
preClose:ref(close,N);

 
3.在一分钟周期取前五分钟最高价怎么取?(对于商品期交所的品种)
N:=BARSLAST(DATE!=REF(DATE,1))+1;
HH:VALUEWHEN(TIME=0905,HHV(H,N));
LL:VALUEWHEN(TIME=0905,LLV(L,N));

 

 


支持(0中立(0反对(0回到顶部