通达信软件    金融实验室    Level2产品    港股产品     美股产品     帮助中心     通达信PC产品2群 通达信PC产品2群 通达信移动产品群 通达信移动产品提升群

通达信用户反馈区软件纵横公式天堂 → 通达信客服公式汇总贴


  共有138852人关注过本帖树形打印

主题:通达信客服公式汇总贴

美女呀,离线,留言给我吧!
queenkeshi
  21楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:7078 积分:37230 威望:0 精华:0 注册:2010/7/6 8:41:00
成交量指标公式  发帖心情 Post By:2012/5/10 9:22:00

在VOL上划线,3根
第一根:多空量=(6日均量+13日均量+26均量)除以3,
第二根:上限=多空量乘以1.382,
第三根:下限=多空量乘以0.618

 

 

VOLUME0509:VOL,VOLSTICK;
多空量:(MA(V,M1)+MA(V,M2)+MA(V,M3))/3,COLORWHITE;
上限:多空量*1.382,COLORRED;
下限:多空量*0.618,COLORGREEN;

 

 


图片点击可在新窗口打开查看此主题相关图片如下0510.jpg:
图片点击可在新窗口打开查看

支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
queenkeshi
  22楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:7078 积分:37230 威望:0 精华:0 注册:2010/7/6 8:41:00
历史量比  发帖心情 Post By:2012/5/22 9:53:00

AA:=VOL;
BBB:=SUM(VOL,5);
IF(CURRBARSCOUNT=1,(5*240*AA/BBB)/FROMOPEN,(5*AA/BBB));

支持(0中立(0反对(0回到顶部
帅哥哟,离线,有人找我吗?
TianJinen
  23楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信 管理员
等级:管理员 帖子:6846 积分:37451 威望:0 精华:9 注册:2002/5/24 7:10:00
  发帖心情 Post By:2012/12/6 10:11:00

 

找出小数等于整数部分的。。。。

XG:INTPART(LLV(L,P))=FRACPART(LLV(L,P))*100 OR INTPART(LLV(L,P))=FRACPART(FRACPART(LLV(L,P))*10)*10;


以上公式不正确,需改为

A1:=INTPART(LLV(L,P));

A2:=FRACPART(LLV(L,P))*100;

A3:=FRACPART(FRACPART(LLV(L,P))*10)*10;

RESULT:ABS(A1-A2)<0.0001 OR ABS(A1-A3)<0.0001;

 

两个浮点数相等要用abs的方式来判断,不能直接用=号


支持(0中立(0反对(0回到顶部
帅哥哟,离线,有人找我吗?
tdxistdx
  24楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:管理员 帖子:1958 积分:10231 威望:0 精华:0 注册:2012/5/12 12:58:00
  发帖心情 Post By:2013/6/9 9:32:00

仿系统的PVI公式:

 

A:=IF(VOL>REF(VOL,1),CLOSE/REF(CLOSE,1),1);
B:MULAR(A,0)*100;
MA(B,72);

{MULAR累积,相当于一种带有上个结果的循环语法}

 


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
queenkeshi
  25楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:7078 积分:37230 威望:0 精华:0 注册:2010/7/6 8:41:00
通达信DLL函数应用  发帖心情 Post By:2014/5/29 14:15:00

支持外部dll的函数应用

调用DLL中的函数.
用法:
TDXDLL1(funcid,param1,param2,param3),funcid为数字,表示调用dll函数编号

 

查看dll函数规范也可以直接点击下图中的“通达信Dll函数编程规范”

通达信DLL函数编程规范

http://help.tdx.com.cn/book.asp

 

 


图片点击可在新窗口打开查看此主题相关图片如下052901.jpg:
图片点击可在新窗口打开查看

 

第一步:ctrl+F关联外部dll

{事例dll 打开规范工程编译生成dll}

 


图片点击可在新窗口打开查看此主题相关图片如下052902.jpg:
图片点击可在新窗口打开查看
绑定显示成功则成功绑定dll 否则参照dll编程规范修改dll

 

 
图片点击可在新窗口打开查看此主题相关图片如下052903.jpg:
图片点击可在新窗口打开查看

第二步:新建公式

 

SC4:TDXDLL1(1,2,3,4);{这个函数 规范中的函数体是后面三个参数都没用,只取的数据的有效数即和barscount等效}
SC5:TDXDLL1(2,2,3,4);{求三个输的平均值}

BARSCOUNT(C);

查看输出{此处使用的就是编程规范的dll}

 

注意

参数只能接受4个,第一个为编程规范中定义的对应函数的函数编号,后面三个位自由参数,如果只有两个参数的函数,最后一个参数任意赋值,但不能为空。

第三步:查看结果输出

 


图片点击可在新窗口打开查看此主题相关图片如下052904.jpg:
图片点击可在新窗口打开查看

支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
queenkeshi
  26楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:7078 积分:37230 威望:0 精华:0 注册:2010/7/6 8:41:00
DRAWICON ID 与 图标对应  发帖心情 Post By:2014/7/10 18:01:00


图片点击可在新窗口打开查看此主题相关图片如下icon.jpg:
图片点击可在新窗口打开查看

支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  27楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/23 17:13:00

 

引用定位

1.三个月的天数

A1:=BARSLAST(MONTH<>(MONTH+1) AND CURRBARSCOUNT>59 AND CURRBARSCOUNT<68);

2.10天到前5天的最高收盘价

N:=CURRBARSCOUNT;

T:=IF(N>10 OR N<5,0,C);

HHV(T,0);

3.上上次满足条件的K线位置

N:=BARSLAST(CROSS(MACD.MACD,0));

A1:REF(N,N+1)+N+1;

4.当前今日最低点出现在9点半到10点半之间

A1:=BARSLAST(DATE<> REF(DATE,1))+1;
A2:BARSLAST(TIME=1030)=LLVBARS(L,A1);

{60分钟周期选股并观察,1030是当天第一根K线的时间};

5. 最低点出现在上午

M:=BARSLAST(DATE<>REF(DATE,1))+1;

A1:=C=LLV(L,M);

A2:=BARSLAST(A1);

A3:=BARSLAST(TIME=1030);

A4:A2>=A3;


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  28楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/23 17:13:00

6.MACD金叉定位

 

{选股公式一:MACD0轴以下的第一次金叉;

选股公式二:MACD0轴以下的第二次金叉;

选股公式三:MACD0轴以下的第三次金叉;

选股公式四:MACD0轴以上的第一次金叉;

选股公式五:MACD0轴以上的第二次金叉;

选股公式六:MACD0轴以上的第三次金叉;}

A1:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA>=0));

X一次金叉:=CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0 AND COUNT(A1=1,50)=1;

A2:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA>=0));

X二次金叉:=CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0 AND COUNT(A2=2,50)=1;

A3:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA>=0));

X三次金叉:=CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0 AND COUNT(A3=3,50)=1;

A4:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA<=0));

S一次金叉:CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA>0 AND COUNT(A4=1,50)=1;

A5:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA<=0));

S二次金叉:CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA>0 AND COUNT(A5=2,50)=1;

A6:=COUNT(CROSS(MACD.DIF,MACD.DEA),BARSLAST(MACD.DEA<=0));

S三次金叉:CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA>0 AND COUNT(A6=3,50)=1;

 


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  29楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/25 10:37:00

 

时间定位

1.某季的最后一天

TJ: MONTH<>REFX(MONTH,1) AND FRACPART(MONTH/3)=0;

2.K线任何一个位置调用最新的收盘价

REFX(C,CURRBARSCOUNT-1);

3.如何获得最后一个交易日距上季度末的天数

方法一:AA:MONTH<>REFX(MONTH,1) AND FRACPART(MONTH/3)=0;BARSLAST(AA);

方法二:XXX:=IF(DATE=1150930,CURRBARSCOUNT,DRAWNULL);

REF(XXX,BARSLAST(DATE=1150930));

4.成交量连续5天放大

EVERY(V/REF(V,1)>1,5);

5.股价创60日内新高

DYNAINFO(5)=HHV(H,60);

6.求前60天至前120天的最高价

方法一:A1:REF(HHV(H,60),60);

方法二:A2:FINDHIGH(H,60,60,1);

7.找出已经高送转过的股票,并且今日涨停

COUNT(FINANCE(7)/REF(FINANCE(7),1)>=2,100)>0 AND C>1.095*REF(C,1);

8. 当日最后一个小时涨停

A1:=BARSLAST(TIME=1400);

A2:=HHV(H,A1)>REF(C,240)*1.098;

A3:BARSSINCEN(A2,240)<60;


支持(0中立(0反对(0回到顶部
美女呀,离线,留言给我吧!
晨云飞燕
  30楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:2668 积分:13566 威望:0 精华:0 注册:2015/10/30 16:28:00
  发帖心情 Post By:2016/4/26 17:51:00

 

成交量相关

1.相邻成交量比较

VOL,VOLSTICK;

AA1:=ABS(VOL-REF(VOL,1))/MIN(VOL,REF(VOL,1))<=0.03;

AA2:=ABS(VOL-REFX(VOL,1))/MIN(VOL,REFX(VOL,1))<=0.03;

IF(AA1 OR AA2,VOL,DRAWNULL),STICK,COLORWHITE,LINETHICK7;

2.成交量柱标成金黄色

{1分钟周期上,每个成交量柱成交金额大于900万的标成金黄色}

M1(2  500  5)

M2(2  500  10)

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,M1);

MAVOL2:MA(VOLUME,M2);

A1:STICKLINE(V*C>9000000,V,0,2.8,0),COLORYELLOW;

3.分别求当天之前的30日内红色成交量之和,与绿色成交量之和。

:SUM(IF(C>O OR (C=O AND C>REF(C,1)),VOL,0),30);
绿:SUM(IF(O>C OR (C=O AND C<REF(C,1)),VOL,0),30);

4.当天第一分钟的成交量

A2:=BARSLAST(DATE<>REF(DATE,1) AND TIME=0931);

A3:REF(V,A2);


支持(0中立(0反对(0回到顶部
总数 35 上一页 1 2 3 4 下一页