通达信软件    金融实验室    Level2产品    港股产品     美股产品     帮助中心     通达信PC产品2群 通达信PC产品2群 通达信移动产品群 通达信移动产品提升群

通达信用户反馈区软件纵横通达信券商集成版 → 招商智远一户通6.18-6.19版本指标显示未通过编译


  共有72人关注过本帖树形打印

主题:招商智远一户通6.18-6.19版本指标显示未通过编译

美女呀,离线,留言给我吧!
bjtj918
  1楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:新手上路 帖子:1 积分:70 威望:0 精华:0 注册:2019/6/12 9:45:00
招商智远一户通6.18-6.19版本指标显示未通过编译  发帖心情 Post By:2019/6/12 10:24:00

网上找的自编指标,以前招商证券版本都能正常使用,最近更新到6.18版本(包括6.19版本)以后,都不能使用,显示未通过编译。这是为什么呢?!不要改的今天这个指标不能用,下次更新又有指标用不了了。现粘贴指标: 水平面:MA(CLOSE,89),COLORFFA2FF; BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4; IF(BBI>REF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2; IF(BBI=1,O,C,2,0),COLORYELLOW; MA13:=MA(CLOSE,13); X1:=(C+L+H)/3; BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10; EMA8:=EMA(C,8); A1:=MIN(O,C); B1:=ABS(O-C); T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10); STICKLINE(T1,A1,A1+B1/4,2,0),COLOR007575; STICKLINE(T1,A1+B1/4,A1+B1/2,2,0),COLORFF0000; STICKLINE(T1,A1+B1/2,A1+B1*3/4,2,0),COLOR007575; STICKLINE(T1,A1+B1*3/4,A1+B1,2,0),COLORFF0000; LC:=REF(CLOSE,1); RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100); FF:=EMA(CLOSE,3); MA15:=EMA(CLOSE,21); {DRAWTEXT(CROSS(FF,MA15),(LOW * 0.97),'底背离'),COLORA6E500; DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),'顶背离'),COLOR1880FF;} STICKLINE(CROSS(FF,MA15),A1,A1+B1/2,2,0),COLOR7F017F; STICKLINE(CROSS(88,RSI),A1+B1,A1+B1/2,2,0),COLORGREEN; T2:=COUNT(CROSS(BBI,3),3)=1 AND CROSS(C,BBI); DRAWTEXT(T2,H*1.05,'反转'),COLORWHITE; STICKLINE(T2,O,C,2,0),COLORRED; T12:=V2>=1; T0:=BARSLAST(T12); L1:=REF(L,T0); H1:=REF(H,T0); STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),H1,H1,4,-1),COLORWHITE; STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),L1,L1,4,-1),COLORWHITE; {T11:=REF(T12,3) AND COUNT(LH1,4)>1; DRAWTEXT(T11,H*1.05,'三天'),COLORWHITE; STICKLINE(T11,O,C,2,0),COLORFF00FF;} {(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) }; L11:=MIN(REF(L,1),L); L10:=MIN(L11,REF(L,2)); L21:=MAX(REF(L,1),L); L20:=MAX(L21,REF(L,2)); T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND ((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1)); T11:=T111 AND REF(T111,1)=0; STICKLINE(T11,O,C,2,0),COLORFF00FF; 高:=REF(HHV(H,N),M); 低:=REF(LLV(L,N),M); H19:=高-(高-低)*0.191; H38:=高-(高-低)*0.382; H中:=高-(高-低)*0.5; H61:=高-(高-低)*0.618; H80:=高-(高-低)*0.809; 顶点:REFDATE(高,DATE),POINTDOT,LINETHICK2,COLORWHITE; %19.8:REFDATE(H19,DATE),POINTDOT,LINETHICK2,COLORYELLOW; %38.2:REFDATE(H38,DATE),POINTDOT,LINETHICK2,COLORGREEN; %50:REFDATE(H中,DATE),POINTDOT,LINETHICK2,COLORRED; %61.8:REFDATE(H61,DATE),POINTDOT,LINETHICK2,COLORMAGENTA; %80.9:REFDATE(H80,DATE),POINTDOT,LINETHICK2,COLORBLUE; 低点:REFDATE(低,DATE),POINTDOT,LINETHICK2,COLORWHITE; DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE; DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE; STICKLINE(T1,A1,A1+B1/2,2,0),COLOR007575; STICKLINE(T1,A1+B1/2,A1+B1,2,0),COLORBLUE; STICKLINE(T11 AND T12,A1,A1+B1/2,2,0),COLORFF00FF; STICKLINE(T11 AND T12,A1+B1/2,A1+B1,2,0),COLORYELLOW; STICKLINE(T1 AND T12,A1+B1/3,A1+B1,2,0),COLORYELLOW; STICKLINE(T1 AND T12,A1,A1+B1/3,2,0),COLOR007575; STICKLINE(T1 AND T12,A1+B1/3,A1+B1*2/3,2,0),COLORBLUE; STICKLINE(T2 AND T12,A1+B1/2,A1+B1,2,0),COLORRED; STICKLINE(T2 AND T12,A1,A1+B1/2,2,0),COLORYELLOW;
 下载信息  [文件大小:   下载次数: ]
点击浏览该文件:立桩量.txt


支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部
美女呀,离线,留言给我吧!
ellen331
  2楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:5066 积分:26528 威望:0 精华:0 注册:2008/7/7 15:36:00
  发帖心情 Post By:2019/6/12 15:58:00

可以新建,保存试一下,若保存不了,有具体的提示的。需要自行对应排查下。

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部

返回版面帖子列表

招商智远一户通6.18-6.19版本指标显示未通过编译








验证码: 验证码,看不清楚?请点击刷新验证码
签名