通达信软件    金融实验室    Level2产品    港股产品     美股产品     帮助中心     通达信PC产品2群 通达信PC产品2群 通达信移动产品群 通达信移动产品提升群

通达信用户反馈区软件纵横通达信金融终端 → 同一个公式选股,条件选股与自动选股设置选股数量不一致


  共有482人关注过本帖树形打印

主题:同一个公式选股,条件选股与自动选股设置选股数量不一致

美女呀,离线,留言给我吧!
JOHNNY25036
  1楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:论坛游民 帖子:17 积分:215 威望:0 精华:0 注册:2018/5/14 13:17:00
同一个公式选股,条件选股与自动选股设置选股数量不一致  发帖心情 Post By:2019/3/14 18:55:00

同一个公式选股,条件
图片点击可在新窗口打开查看此主题相关图片如下err.png:
图片点击可在新窗口打开查看
选股与自动选股设置选股数量不一致,其中条件选股能选择正确,而自动选股选择有缺失。

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部
美女呀,离线,留言给我吧!
ellen331
  2楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:5920 积分:30820 威望:0 精华:0 注册:2008/7/7 15:36:00
  发帖心情 Post By:2019/3/15 14:24:00

公式贴出来,我们试一下

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部
美女呀,离线,留言给我吧!
JOHNNY25036
  3楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:论坛游民 帖子:17 积分:215 威望:0 精华:0 注册:2018/5/14 13:17:00
  发帖心情 Post By:2019/3/16 1:07:00

{高涨幅5%股票}
TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJ1X:=COUNT(TX=0,100)=0;
TJ2:=COUNT(T2L=0,100)=0;
TJ3:=COUNT(T3L=0,100)=0;
TJ4:=COUNT(T4L=0,100)=0;
TJ5:=COUNT(T5L=0,100)=0;
TJA:=C>REF(C,1)*1.05;
AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200); 
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:CROSS((XGT=0 AND D3) OR D6=0,0.5);

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部
美女呀,离线,留言给我吧!
JOHNNY25036
  4楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:论坛游民 帖子:17 积分:215 威望:0 精华:0 注册:2018/5/14 13:17:00
  发帖心情 Post By:2019/7/24 6:54:00

怎么都没有答复?公式都贴出来了。

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部
美女呀,离线,留言给我吧!
ellen331
  5楼 个性首页 | 博客 | 信息 | 搜索 | 主页 | UC


加好友 发短信
等级:超级版主 帖子:5920 积分:30820 威望:0 精华:0 注册:2008/7/7 15:36:00
  发帖心情 Post By:2019/7/24 9:39:00

用系统自带的公式,15:45之后下载数据盘后选,然后截对比图

支持(0中立(0反对(0单帖管理 | 引用 | 回复 回到顶部

返回版面帖子列表

同一个公式选股,条件选股与自动选股设置选股数量不一致








验证码: 验证码,看不清楚?请点击刷新验证码
签名